Marlin Firearms Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
ok all looking for some advice on an issue with my 1895 4570. The magazine tube will hold the standard four rounds, and will load the first round every time without any problems. After that round is discharged and i work the lever to feed the next round, the case will only eject about half an inch out of the mag tube preventing the lever from moving from its fullest extended position. A screwdriver/gerber is required to pull the stuck round out of the mag tube into battery. Once the case is released and chambered the rifle works fine, but again after its fired the next round will only come half an inch out of the tube. I thought possibly that the mag tube might be slightly angled to one side, causing the failure to feed. I have shot winchester 300gr jhp, remington 300gr jhp, and hornady 325gr leverevolution ammo through it and had the same issue with all three types. Any ideas on whats going on here?
 

·
Registered
Joined
·
633 Posts
Use the search engine on the home page with "failure to feed 1895", should come up with some things to check.
 

·
Registered
Joined
·
208 Posts
Had the same issue with mine and just went on the 'attack' with fine grit, steel wool and scotch brite. Stripped right down, gave mag tube a thorough clean with 12Ga brass brush, mop etc and a light oil. Gave the mag follower (metal WWG follow) a light rub down with steel wool and scotch brite. Gave receiver 'entry point' of mag a light polish. Polished all machine marks off the carrier and gave a polish. Thorough cleaning of all internals with gun solvent, getting into every nook and cranny, then gave everything a thorough blast with airgun/compressor. Light oil, put back together and no more issues, as long as I do this on a semi-regular basis.
Where I am and where I take the 1895, there is a lot of sand and gravel - I live on a rock!!! That stuff gets everywhere and can easily cause issues with follower/mag tube and also get in between carrier and receiver causing the odd hang-up.
 

·
Registered
Joined
·
671 Posts
Did you just get the rifle? New or used? If so check to make sure the plunger in the tube is not in backwards. If it is backwards it will be causing the problem. Simple and easiest thing to check before you really start to tear things down.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
ok all stripped the marlin 1895 4570 down cleaned the crap out of it, ordering a new metal follower and spring, polished the mag tube and stretched the existing spring. The current plastic factory follower is in correctly. Will have to wait a week or two to run some more ammo through it, after that test, if it still malfunctions i'll try the new follower and spring, which will get installed anyway, and if it still continues to give me problems, i'll try to bend the shell lifter down slightly and polish the inside of the mag tube a tad more. I've got a good plan of action here thanks to the resources from you all. Ill keep my fingers crossed that we can get my marlin running flawlessly...appreciate all the advice guys.
 
1 - 6 of 6 Posts
Top