Marlin Firearms Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi folks! I am new to the site and have posted this question earlier today , maybe in the wrong thread. If anyone can help I would greatly appreciate it! I have a camp 9 that I have replaced the hammer strut bridge, hammer strut, hammer strut spring, and also the recoil buffer. Also replaced the recoil spring with a Wolff 16 lb. spring. After re-assembling the gun, I fired 4 rounds through it. The 5th round chambered but the trigger would go all the way back and not fire. I removed the clip and the previously chambered round. The hammer was back and would not go forward. I put the empty magazine back in. The only way the hammer will fall is if I hold the trigger back and then pull the bolt open and let it go forward while continuing to hold the trigger to the rear. Again the rifle will cock when I pull the bolt to the rear but will not fire when the trigger is pulled. Hammer will only fall when trigger is held back and the bolt is pulled back and then released. Any ideas? Thanks in advance!
 

·
Registered
Joined
·
363 Posts
Did you do any other disassembly?

If you havent done it, review the stickies for the rebuilding of the trigger assembly, see if something doesnt catch your eye. Im assuming you verified that the gun shot normally before this all occurred?

It almost sounds like you have something in wrong or possibly a sear issue of some sort; maybe the rear sear spring moved/installed backwards/broken etc.
 
1 - 2 of 2 Posts
Top