Marlin Firearms Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Bought a new 925M a couple summers ago. Haven't done much with it because with each magazine it came with I need to press up on the bottom of the magazine as I'm sliding the blot forward in order for the next live round to be stripped and fed into the chamber. If I don't push up on the magazine the round doesn't feed. It seems as though there is about 1/4 inch of play when I push on the magazine. Any ideas on how to fix myself or if the factory will take care of this for me since this is how I purchased it new. Thanks
 

·
Registered
Joined
·
25,048 Posts
andrew in rimfire can probably help you most with this .. I would say the lips need tweaked .. contact him or one of the others like arrowdodger that are experts in the rimfires..
 

·
Super Moderator
Joined
·
13,316 Posts
I agree, the lips need to be tweaked. It sounds like they're holding the cartridges too far down into the magazine allowing the bolt to slip right over them.

After you tweak them (with non marring tools) clean them out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks for the replies. So you guys think it's the lips that need opened up. That surprises me because there's play in the magazine for me to push up on. I'll try it. Thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I tried the magazine lips. Didn't seem to work. I couldn't make it so the rounds rode high enough and there was still enough tension to actually hold the rounds in. Still appears to be that the magazines are held high enough in the receiver.
 
1 - 5 of 5 Posts
Top